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VxBackup User Manual 

Section 1 Introduction 

VxBackup is mainly used to back up the history data. 

1.1 Main Functions 

The VxBackup software mainly has the following functions: 

 Support manual backup and automatic backup 

 Support local backup and remote backup 

 Backup content includes historical trend, historical alarm, operation log and project 

configuration 

 Backup data supports offline view 

1.2 Typical Network 

VxBackup can backup and view the history data of multiple project. As shown as figure below, the 

client running VxBackup can backup and view the history data of Project1 and Project2. 

 

Figure 1-1 Typical Network of VxBackup 
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1.3 The Data Backup Flow of High-performanceHMI System Project 

You can realize the data backup in High-performanceHMI system project by VxBackup and view 

the history data by the offline viewer. 

 

Figure 1-2 The Data Backup and View of High-performanceHMI System Project Data 

 

1.4 The Preparation Task 

Digital signal operated in control strategy is output to DO module by DOEX tag to indicate or 

control field executor.  

The following conditions shall be met before you start VxBackup. 

 Install VxBackup. 

 Start VxBackupServer. After High-performanceHMI is installed, VxBackupServer is 

automatically started by default. 
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Section 2 Start Software and Backup the Data 

This section mainly introduces the method to baking up data by VxBackup. 

2.1 Start Software and Login 

Before using VxBackup for data backup, you need to start VxBackup and log into it. 

Non first login 

1) Select the command OMC High-performanceHMI Backup Tools > DataBackupTool 

from the start menu to bring up the VF Data Backup Client software. 

2) Log into VxBackup after entering the password in Password. 

First login 

When the user logs into VxBackup for the first time, the user's initial password needs to be 

modified. 

1) Select the menu command Manage > User Login to bring up the Modify Password 

dialog box. 

2) Enter the “admin” in the Original Password. Enter the new password in the New 

password bar. The new password shall be no less than 8 characters and contain 

numbers and letters. 

After modifying the password, when you log into VxBackup again, you can perform the property 

setting of manual backup, automatic backup and so on. 

2.2 Add New Project and Configure the Project Property 

You can designate the project that VxBackup needs to back up by creating a new project. The 

specific steps are as follows. 

1) Click  in the toolbar and a new item New Project will be added to the project 

navigation tree called. 

2) Configure the backup properties of the new project, such as the VxBackup project name 

of the backup data and the saving path of the backup data. 

Click New Project and then the figure below will be displayed on the right side. 
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  Figure 2-1 VxBackup Project Property Settings 

Configure the project by the following table. 

Configuration Item Function Description Configuration Description 

Name The project name of VxBackup Input in the textbox 

Project Name by 
High-performanceHMI 

It is used to back up the 
High-performanceHMI project for 
VxBackup related to the configuration.

Not editable 

SOnet address of the 
configuration server 

It is used to designate the IP address of the 
SOnet of the nodes the 
High-performanceHMI project belongs to 
and this High-performanceHMI project is 
associated with VxBackup project.

Not editable 

Config Server Backup 
Network Address 

It is used to designate the IP address of the 
configuration server corresponding to the 
backup project.

Click “…” and configure it in 
the pop-up dialog box.  

Path 
It is used to designate the saving path of 
the backup data.  

Click “…” and configure it in 
the pop-up dialog box.  

Warning Value of Disk 
Free Space 

It is used to designate the disk stores the 
backup data and the alarm threshold. 
When the disk space is less than this 
threshold, the alarm will be triggered. 

Input in the textbox 

Enable Backup or Not 
It is used to determine whether to enable 
the backup function of the current project. 

Select in the drop-down list 

 

3) Load High-performanceHMI project. 

 Select Offline Load from the right-click menu of New Project. In the Open dialog box 

that pops up, select the High-performanceHMI project that has been backed up. The 

High-performanceHMI project backup file is a .zip file. The .zip file is generated after the 

project backup is executed in the VFSysBuilder. For details, please refer to 

《VFSysBuilder User Manual》 

 Select Online Load in the right-click menu of New Project. The configuration server 

would be identified as per the IP address of the backup network of the configuration 

server, and the default project in the configuration server would be loaded. 
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2.3 Manual/Auto Backup 

After designating the High-performanceHMI project that the VxBackup associates with by 

configuring the project properties, you can manually or automatically backup 

High-performanceHMI project. 

2.3.1 Automatic Backup 

Before performing automatic backup, you need to designate the automatic backup period, 

execution time, and other attributes. The specific steps are as follows. 

1) Select the project in the configuration tree and its sub-nodes are shown in the figure 

below. 

 

  Figure 2-2 VxBackup Project Configuration Tree 

2) Configure trend, log and the start time of the alarm 

Select one operational station node such as “OA3133” as shown in the figure above and 

the right area will be shown as the figure below. In “trend start date”, “log start date” and 

“alarm start date”, you can configure the trend in the domain, log and the backup start 

time of log and alarm data. 

 

Figure 2-3 Configure the start time of trend, log and alarm 

3) Configure the backup cycle and execution time of the automatic backup. 
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In the configuration tree, configuration, configuration log, log and alarms of domain server, 

history data server can be selected, and you can set the backup properties of the 

High-performanceHMI configuration, High-performanceHMI configuration log, log and 

alarm in the High-performanceHMI specified domain server, and the backup properties of 

history data server including the backup cycle and the execution time. 

 Backup cycle, supports day backup or week backup. 

Click ... to bring up the Backup Cycle dialog box as shown below. 

 

   Figure 2-4 Backup Period Configuration Dialog Box 

Select Interval Days and select the backup interval in the drop-down list. 

Select Backup by Weeks and select the specific time to perform the backup in the 

list. 

 Execution time is used to specify the start time of automatic backup. 

Click ... and configure the specific time in the Execution Time dialog box that pops 

up. 

4) Click  on the toolbar to enable the VxBackup backup function. VxBackup will back up 

the data according to the settings of the automatic backup. 

 

 
Tip: 

Backup is executed as per the strategy as VxBackup is running, and before it ends, the 

tasks being backed up and those in the task list should be backed up. The backup task 

beyond the running cycle wouldn’t be backed up. 
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2.3.2 Manual Backup 

In addition to supporting automatic backup, VxBackup also supports random manual backup 

operations. 

 Backup by project 

In the navigation tree, select the project to be backed up and select “Backup Now” from 

the right-click menu. 

 Backup by content 

In the navigation tree, select the content to be backed up, such as Configuration Log, 

Alarm, etc., and select Backup Now in the right-click menu. 

2.3.3 View the Backup 

After the automatic backup or manual backup is started, the backup process will be displayed in 

the right area as shown in the figure below. 

 

Figure 2-5 Backup Case of VxBackup 

  

In the backup condition of VxBackup, the following information is mainly included. 

Project Function Description 

Project It displays the VxBackup project name corresponding to the backup task.  

Domain Name 
It displays the operation domain name of High-performanceHMI corresponding to the 
backup task.  

Data Type 
It displays the High-performanceHMI data types corresponding to the backup task, 
including log, alarms, configuration and configuration operation log.  

Name 
It displays the last two digits of the server IP address or node name of the object being 
backed up. 

Current Status It displays the status of the current backup task.  

Status of last time 
backup 

It displays the status of the last time backup task.  

The ending time of 
last time backup 

It displays the execution time of last time backup task.  

The ending time of 
next time backup 

It displays the execution time of next time backup time under the circumstance of 
automatic backup.  

 

2.4 Disk Left Space 

 Reminder 
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When the size of the hard disk of the VxBackup backup data is smaller than the 

configured “hard disk free space”, the message “Hard disk space will be full” will be 

displayed in the system tray, and the status bar will turn yellow. After the prompt message 

appears, the backup data should be processed in time to ensure that the backup data 

can be backed up. 

 Insufficient space 

When the hard disk backup space is less than 1G, the backup task will stop.
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Section 3 View the Backup Data 

After VxBackup performs backup, the backup data can be viewed through offline viewing software. 

 
Tip: 

Only the configuration is well backed up, can the configuration log, trend and alarm be 

viewed by the offline tool. 

 

3.1 View the Operation Log 

You can view the operation logs of VF backups by the log offline viewing tool. At the same time, 

the operation log offline viewing tool also supports filtering logs by time, nodes and so on. 

3.1.1 Designate the Operation Log to View 

You can view the operation logs of VF backups by operating the log offline viewing tool. 

1) Select OMC High-performanceHMI Backup Tools > Operation Log Browser from the 

start menu to bring up the dialog box shown below. 

 

  Figure 3-1 Select the backup path of the operation log 

2) Select the path of the operation log backup in the Backup Project Path and click OK to 

enter the operation log viewing interface, as shown in the following figure. 

 

Figure 3-2 The offline view case of the operation log 
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3.1.2 Filter Operation Log 

Fast Filter operation log as per time 

All the backed up operation logs are listed in the operation log and the operation log can be filtered 

through the Browse by Day toolbar. 

1) Select Browse by Day in the toolbar and the subsequent date control will become 

optional. 

2) Click  or select the specified date in the check box  in the date 

control shown below. 

 

  Figure 3-3 The time filtering control of the operation log 

Filter operation log as per conditions 

All the backed up operation logs are listed in the operation log and the detailed filter conditions can 

be specified by Filter in the toolbar. 

1) Select Filter in the toolbar, and the subsequent filter button will take effect and be 

displayed as . 

2) Click  to bring up the Filter dialog box as shown in the figure below. 

 

  Figure 3-4 The offline view case of the operation log 

3) Configure detailed filter conditions according to the table below. 
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Configuration Item Function Description Configuration Description 

Time 
It is used to designate the start and 
end time of viewing the operational 
log  

Tick the check box and configure 
the start and end time.  

Show Info 
It is used to designate the items 
displayed in each page of the 
operation log.  

Configure in the drop-down list.  

Event 
It is used to designate whether to 
filter the operation log as per 
conditions.  

Tick in the check box. After being 
ticked, the filtering condition can 
be configured.  

Node 
It is used to designate the nodes the 
operation log belongs to. 

Input in the textbox. 

Type 
It is used to designate the type the 
operation log belongs to. 

Input “user”, “system” in the 
textbox.  

User 
It is used to display the operation log 
associated with the user.  

Input in the textbox. 

Object 
It is used to display the object the 
operation log includes.  

Input in the textbox. Generally, it 
is the start management. User 
login, configuration release and 
reload.  

Tag 
It is used to display the tags the 
operation log includes.  

Input in the textbox.  
After ticking “Matching the tag 
name accurately”, only the log 
with the same tag name can be 
displayed.  

Event 

Other 
It is used to set the other conditions 
for filtering the operation log.  

Input in the textbox. 

 

4) Click "Filter", the operation log will be displayed according to the filter condition in the log 

list. 

3.2 View History Alarms 

Through the history alarm offline viewing tool, you can view the backed up history alarms by 

VxBackup. 

1) Select OMC High-performanceHMI Backup Tools > History Alarm Browser from the 

start menu to bring up the dialog box shown below. 

 

  Figure 3-5 Select the backup path of the alarm log 
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2) Select the path of the history alarm backup in the Backup Project Directory and click 

OK to enter the history alarm viewing interface. 

In the history alarm offline software, you can manage history alarms, such as filtering history 

alarms, exporting history alarms, and so on. For details on how to use the history alarm offline 

viewing software, please refer to the 《History Alarm Offline Viewer User Manual》. 

3.3 View the Offline Trend 

With the trend offline viewing tool VxDataAnalyzer, you can view offline trend of the backup by 

VxBackup. 

1) Select OMC High-performanceHMI Backup Tools > History Trend Browser from the 

start menu to bring up the software interface as shown in the figure below. 

 

 

 

  Figure 3-6 The initial interface of the trend offline software 

2) Click the button in the toolbar and select the configuration for which you want to view the 

trend in the pop-up Configuration Selection dialog box. 
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For details on how to use the trend offline viewing tool, see the 《VxDataAnalyzer User Manual》. 

3.4 View the Configuration Log 

You can view the configuration log backed up by the VxBackup through the offline viewer of the 

configuration log. 

1) Select OMC High-performanceHMI Backup Tools > CfgLog Browser in the start 

menu to bring up the dialog box shown below. 

 

  Figure 3-7 The selection dialog box of the configuration log 

2)  Select the path of the configuration log backup in Backup Project Path and click OK to 

enter the configuration log view interface, as shown in the figure below. 

 

Figure 3-8 The case for viewing configuration log 

3.4.1 Filter Configuration Log 

The configuration log viewer supports filtering configuration logs by time and types. 

Filter configuration log as per time 

1) Select the time range of the log to be viewed in the Start Time and End Time in the 

toolbar. 

2) Click Query and the log will be displayed in the log list as per the filtering conditions. 

Filter configuration log as type 

1) Select the type of log to be viewed in the drop-down list of Type in the toolbar. 

2) Click Query and the log will be displayed in the log list as per the filtering conditions. 
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3.4.2 Export Configuration Log 

The configuration log viewer supports exporting configuration logs as a csv file. 

1) Select File > Export from the menu. 

2) In the Save As dialog box that pops up, select the export path of the log and configure 

the file names. 

3) Click Save to export the configuration logs. 
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Section 4 Revision 

Table 4-1 Retrofit list of the version 

Document Version Applicable Product Version Remarks 

V1.0 (20230301) 
OMC High-performanceHMI 
V4.70.00.00 

First release 

V1.1 (20230830) 
OMC High-performanceHMI 
V5.10.00.00-M 

Updated screenshots. 
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